云南网站建设创新企业 昆明多彩网络公司

|网页对话|电话:0871-63215311

“多浏览器版本”问题

来源:昆明网页设计 日期:2010-07-18 阅读: 发表评论

用非标准的标记和代码创造多个版本,每一个都迎合不同浏览器的“癖好”,这是困扰大多数网“永久淘汰”的根源, 目标总是在后退,游戏规则永远在改变。

用非标准的标记和代码创造多个版本,每一个都迎合不同浏览器的“癖好”,这是困扰大多数网站“永久淘汰”的根源, 目标总是在后退,游戏规则永远在
改变。

尽管这种做法是昂贵的、无效的、不可忍受的,但实际工作中仍然有很多人这样做。面对一个支持Web标准的浏览器,许多开发者仍然把它当成不支持,
因此,尽管IE6能够处理标准的ECMAScript和DOM,而人们却继续写探测脚本来判断浏览器是否是IE6,并调用针对Ⅲ的脚本来适应它。尽管Netscape能够处理标准的ECMAScript和DOM,他们仍然习惯于为最新的Netscape浏览器写独立的脚本和代码。

用一个例子来说,在今天有利于标准的环境下,浏览器探测技术和针对性的版本创建是不必要的。事实上,这样做更加糟糕,在不断升级变化的情况下,不是所有的站点管理者都能负担得起,因此探测脚本常常失败。

例如,在Wlndows系统下,Opera浏览器将自己定义为IE,这样做主要为了避免被一些只允许Ⅲ访问的网站(比如许多银行站点)屏蔽。但是为Ⅲ专门写的脚本很可能在Opera浏览器中失败。当Opera浏览器定义自己为IE(这是安装时的默认值),并且开发者写了Ⅲ专有脚本时,访问网站就会失败,用户会受到极大挫折。用户有权选择他们的浏览器,有权设置Opera以自己的身份识别而不以Ⅲ来替代,但是只有很少用户知道这样的操作,他们也不需要知道。

除了私有脚本外,开发者还写那些需要占用两倍带宽的表现层标记,或者提供一个难以被搜索引擎、非主流浏览器和设备访问的服务页面。这些策略会导致很多问题,他们被迫进行解决:在不同浏览器下看到的界面不一样。

多版本带来不断增加的成本和难题。“DH丁ML”网站产生于Netscape4和IE4的不同的不兼容的脚本,但是它们现在又不能工作在新版浏览器上了,网站所有者应该将更多的钱花在这个问题上吗?请开发者建立第5甚至第6个版本?如果他们没有为这些版本做预算怎么办?那么许多用户将被网站拒绝。

同样,开发者可能花费巨大的时间和资源来建造一个“无线”的版本,却发现他们用的无线标记语言已经过时,或者他们的无线版本在新的流行设备中无法访问,一些网站重新建立一个新版本,另外一些只能发布令人为难的消息,许诺在“不远的将来”支持新设备。

那些对旧式方法忍痛割爱的设计师和开发者在运用像XHTML和CSS这样的Web标准技术时,往往不得要点。而更多墨守成规的设计师和开发者由于坚
决不采用标准来避免多版本问题,创建的多个特定浏览器和平台的CSS文件均自相矛盾,自取灭亡。

这些做法浪费时间和金钱,自从西方经济进入百年低迷后,日用品不再丰富,也没有特别的补给。更糟的是,用昂贵的做法去解决问题依然失败。网站依旧破
产,用户依旧被拒绝。

发表评论评论列表(有 条评论)

网页对话 0871-63215311